Inicio > Zona Linux > Actualizar PHP 5.1.6 a PHP 5.2.13 en RHEL/CentOS 5

Actualizar PHP 5.1.6 a PHP 5.2.13 en RHEL/CentOS 5

php versión 5.1.6

Como todos sabemos, ciertas distribuciones que se orientan a servidores, por lo general no incluyen los últimos paquetes de software, este es el caso del paquete PHP usando RHEL/CentOS 5.x, la versión que viene por defecto es la 5.1.6, mientras que la última versión al día de hoy es la 5.2.13, que tiene muchísimas nuevas características que hacen la vida del programador mucho más fácil.

Para instalar esta versión vamos a basarnos en los repositorios de Jason:

Importamos la clave pública:

rpm –import http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

Creamos el .repo:

nano -w /etc/yum.repos.d/utterramblings.repo

Pegamos esto dentro del archivo:

[utterramblings]
name=Jason’s Utter Ramblings Repo
baseurl=http://www.jasonlitka.com/media/EL$releasever/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://www.jasonlitka.com/media/RPM-GPG-KEY-jlitka

Ya estamos listos para correr:

#yum install php o yum update php.

php versión 5.2.13

Categorías:Zona Linux
  1. carlos
    marzo 15, 2011 a las 8:52 pm

    estos repositorios no funcionan y por lo tano no instala bien, por lo menos a mi no me funciono me funcion esto.
    sin problemas.

    http://rm-rf.es/instalar-php-5-2-10-a-traves-de-yum-en-centos/

    exitos

  2. julio 5, 2011 a las 9:47 am

    ¿Y qué podemos hacer con los “Transaction Check Error”?

  1. No trackbacks yet.

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: